Bad asynchronous reprojection with newer versions!

Trinus Forum Forums Trinus PSVR Bad asynchronous reprojection with newer versions!

This topic contains 52 replies, has 7 voices, and was last updated by  Dekaid 4 months, 3 weeks ago.

Viewing 15 posts - 1 through 15 (of 53 total)
  • Author
    Posts
  • #7642

    acsdani
    Participant

    If I allow asynchronus reprojection in the newer versions I get double frames!
    (In SteamVR double/triple lines showing when I turn my head…)

    I didn’t have this problem before! (I need it because the games so much smoother with it.)
    The last version that is working fine for sure is 0.9.2

    0.9.4 affected
    0.9.3h affected (the beta build you linked in another topic)

    Already tried:
    – disable/enable v-sync in Trinus/Radeon Settings (I got rx580)
    – installed latest amd driver
    – disable freepie input
    – 60 Hz seems to not affected, only 90 Hz and 120 Hz

    #7697

    acsdani
    Participant

    Now I tested 0.9.5c and the problem still persist!

    One thing to mention is that I’m not sure the problem is directly in asynchronus reprojection,
    because even when I switch it off, -however the ghosting issue is gone- , there’s still a little lagg
    in every second.

    I tried Fullscreen mode too: It switches the PSVR display to 60 Hz, and there is no way to switch
    it back to 120 Hz, even when the Windows Display Prop. shows 120 Hz, it’s clearly working at 60 Hz
    (I can see the flickering on the white areas.) The ghosting issue is gone this way but it’s clearly
    because of the 60 Hz… and the small lagg is still there.

    #7698
    loxai
    loxai
    Keymaster

    I still don’t have a solution for this. But I have some more tests to try: https://trinusvirtualreality.com/files/psvrTest.zip
    Are you running Trinus (both 0.9.2 and test builds) with default settings? If not, let me know the changes.

    #7699

    acsdani
    Participant

    Now I tried this test build (0.9.6) and still the same issue.

    I’m using the default settings in both builds, except I set the PSVR Display to DISPLAY2!

    In 0.9.2 this is the only way to get smooth movement.
    DISPLAY1 and — gives the same ghosting issue as in the new builds.

    (In the new builds disabling asynchorous reprojection only makes ghosting gone when
    using DISPLAY1 or —. But this way there is the lagging issue so this is not a solution.)

    #7700

    wdnnl
    Participant

    The hdmi headless that I bought has already arrived today,so I tested 120hz on the latest 0.95c and the previous 0.94d, I could not break through 60~65fps. I downgraded to the 0.92 version and achieved 120fps successfully. I would like to say that some of the current new versions are compared with 0.92, some key things may be missing.

    @acsdani, Thank you very much for your guidance, you are my hero!

    #7701
    loxai
    loxai
    Keymaster

    Ok, two new builds to test:
    https://trinusvirtualreality.com/files/psvrTest1.zip
    https://trinusvirtualreality.com/files/psvrTest2.zip
    Also, please check cpu/ram consumption difference with 0.9.2, as shown in Task Manager.

    #7702

    lecitron64
    Participant

    Hi, i recently try your two solutions. Test 1 and 2, full screen and extend mode and is impossible to activate async reprojection.

    With version 0.92 it´s impossible too.

    My ring is a i5 4590 and nvidia 1060 6gb with lastest drivers.

    Maybe are you spanish, loxai? The i could speak in spanish too, to clarify the problem.

    • This reply was modified 7 months, 1 week ago by  lecitron64.
    #7704

    acsdani
    Participant

    For both builds the weird lagg is gone! But the ghosting is still there when asynchorous reprojection is enabled. 🙁

    + For both builds the PSVR Display selector is not working. Even with the ‘Alt.Display Select’ it’s
    at the PC monitor, so I have to use Win+Shift+Right.

    @lecitron64 What do you mean with “impossible” to activate? It’s greyed out in SteamVR’s settings or what? For me with 0.9.2 async. repr. works like a charm! (i7 2600k, RX580)

    #7705
    loxai
    loxai
    Keymaster

    @lecitron64, I am spanish, but better to stick to english here.
    @acsdani, good to know we got some improvement. I removed big chunks of code to see what’s causing problems (inc. move window functionality), now I’ll be building tests with re-added sections to locate the source of trouble.

    #7706
    loxai
    loxai
    Keymaster
    #7707

    acsdani
    Participant

    Nice! I tested this Test3, and it’s still OK when async. disabled! (With async. it’s still ghosting).

    (I noticed that the last two versions had a flickering problem with freepie, but this
    recent one don’t have this issue!)

    #7708

    lecitron64
    Participant

    @acsdani When I try to check async reprojecton happened nothing. It’s status is off although checkbox is ticked.

    Experience is so bad that I suffer sickness in elite dangerous.

    • This reply was modified 7 months, 1 week ago by  lecitron64.
    • This reply was modified 7 months, 1 week ago by  lecitron64.
    • This reply was modified 7 months, 1 week ago by  lecitron64.
    #7712
    loxai
    loxai
    Keymaster
    #7713

    acsdani
    Participant

    @loxai Test4 has the weird lag issue! (It’s a stuttering that comes only when I move my head.)

    @lecitron64 I think it’s not an issue with Trinus. I read on some forums that it could be related to Nvidia settings. Here is a quote from reddit: “…changing the prerendered frames amount in the Nvidia control panel will make it go away or turn on. Forget the exact details but might be something worth messing with.”

    #7714
    loxai
    loxai
    Keymaster

    Ok, getting closer. Two more tests:
    https://trinusvirtualreality.com/files/psvrTest5.zip
    https://trinusvirtualreality.com/files/psvrTest6.zip
    I think 5 will still have the lag, but 6 should not.
    For all the tests we’ve done, you have the FreePIE option disabled, right? (you mention you enabled it, but just as an extra test, correct?)

Viewing 15 posts - 1 through 15 (of 53 total)

You must be logged in to reply to this topic.