Bad asynchronous reprojection with newer versions!

Home Forums Trinus PSVR Bad asynchronous reprojection with newer versions!

This topic contains 52 replies, has 7 voices, and was last updated by  Dekaid 2 months, 4 weeks ago.

Viewing 15 posts - 31 through 45 (of 53 total)
  • Author
    Posts
  • #7756

    Dekaid
    Participant

    Yea I did try it on my PSVR, it felt like the ghosting was gone, tho it could also just be that the turning speed was too high for me to even notice it as this psvrtest still has the same problems somehow…
    I’m still not completely sure if there isn’t a bottleneck on my end though, seeing how I cant even get 120hz to run in 0.9.2 (except for enabling reprojection ofc), running just the steamvr dashboard (just the white space) actually gives me 120hz on any version, but as soon as I start any application (even steamvr home and only looking at the floor) it goes down, but looking at my task manager none of my pc components are even remotely close to high usage

    #7757

    EdZein
    Participant

    Same issue with latest test version.

    tried steamvrtest, without PSVR display.

    No ghosting on monitor. I used rivatuner to check fps, test starts out at 60fps(seems capped) but only running GPU at 1600Mhz before quickly clocking GPU down to 899Mhz and producing 30-40fps for the rest of the duration(before manually forcing close). Not utilising full GPU speed.

    PhoneVR_sdk.exe(steam test file) takes 41% CPU usage and 39% GPU usage(Task Manager) before even starting steam VR (on my pc).

    #7758

    lensman
    Participant

    seems im in the same boat as lecitron,tried quite a few of the test builds and latest version and still get ghosting,so much so the motion sickness makes things unplayable.

    went back to 9.2 (thanks acsdani) same thing.

    with all versions the async switch in steam developer options does nothing,(same as lecitrons problem) always shows as off in its status to the left.
    heres the weird thing: in 60hz steamvr display timing shows massive cpu late starts,its just looks like one long red bar and serious juddering,90hz solves this with just the odd small spike but then the image ghosts badly when looking around.

    another weird point is steam vr home room sometimes runs smooth other times juddery,both times with no ghosting!!

    spec is:

    win 10 (win7 would only work in a mirrored display@60hz)
    fx6300 @ 4.5ghz
    gtx970 @ 1500/6000
    steamvr test score 6.8 well into the green

    cheers!

    #7760

    Dekaid
    Participant

    I re-checked both the SteamVRTest and the PSVRTest that was made based on the SteamVRTest’s changes using Fraps. It appears with any version of Trinus, SteamVR only ever gets to 90fps, the SteamVRTest was the only one that got 120fps while the PSVRTest after, again, only got 90. Whats even weirder to me is the setting always-on reprojection makes it feel like 120fps but fraps still only shows 90.

    Going by this, I should be able to set my monitor to whatever refresh rate I want and my psvr to 90hz and it should work okay, but it doesn’t really feel as smooth as 90hz should.

    So basically:
    – SteamVR can run at 120fps for me as the SteamVRTest shows
    – SteamVR only hits 90fps for any TrinusPSVR version, even the one that was made based on the changes of SteamVRTest

    … weird.

    • This reply was modified 4 months, 2 weeks ago by  Dekaid.
    #7769

    wdnnl
    Participant

    I installed the newest 0.96 yestoday, sadly, I still cannot get 120hz, when I returned to the 0.92 version, the great 120hz world is back too.

    #7770
    loxai
    loxai
    Keymaster

    I still don’t have a solution for this, but I’ve prepared a new test to try:
    https://trinusvirtualreality.com/files/psvrTestx64.zip
    You can try this version in the usual way and see if it improves.
    Alternatively, you can try the ‘Delayed Single Display Start’ option to use a single display (ie. disconnecting all displays but PSVR). This option automates the start up to avoid navigating Trinus/Desktop through the PSVR.

    #7771
    loxai
    loxai
    Keymaster

    And here’s another test where I am disabling a functionality that should not be related… but worth trying:
    https://trinusvirtualreality.com/files/psvrTestV2.zip

    #7776

    acsdani
    Participant

    psvrTestx64:
    The PSVR’s orientation is not working. And often it freezes.

    psvrTestV2:
    Bad ghosting with asynchronous reprojection. With disabled asynchronous reprojection it’s OK, + no weird stuttering.
    ______________________

    It’s so sad that it’s months now and still no solution… πŸ™

    0.9.2 is almost perfect! It just has the annoying FreePIE flickering issue BUT that you know how to solve, it’s already done… http://oddsheepgames.com/?topic=psvr-and-freepie-stopping

    Can’t you just make us an alternate build we can use instead the new “official” one? Like a 0.9.2 but with the FreePIE fix.
    I would be extremely thanful if you could do that!

    It’s been months now, and many of us tried to test the builds you sent. I think we did everything we can…
    And still you could try the idea I mentioned before, that you take the 0.9.2 and add the new features of 0.9.6 but with
    one by one. I think we could find the problem’s source!

    #7777
    loxai
    loxai
    Keymaster

    I would do that (mixing with 0.9.2), but I’m afraid it is not possible.

    So V2 is working like 0.9.2, except for needing async reprojection off?

    #7778

    acsdani
    Participant

    I tested further and V2 is not that smooth like 0.9.2 (both tested with async. r. OFF.)
    It has some rare stuttering, and the image is not that clear, its like when there’s no Anti-aliasing. But maybe it’s all related…
    _____________________
    BUT accidentally I discovered something AWESOME to get the 0.9.6 version working !
    I’m so happy! πŸ˜€
    It can be a temporarly workaround for everyone who only get 0.9.2 working correctly:

    1. Backup the 0.9.2 version’s folder to somewhere! (c:\Program Files (x86)\TrinusPSVR\)
    2. Install the latest version! (0.9.6 currently)
    3. Start the 0.9.2 version. (You backed up before)
    4. When you are in Steam VR and everything is fine, leave Steam VR running, but exit Trinus PSVR.
    5. Start the latest version!

    This way it’s working smooth like 0.9.2 but now with the 0.9.6 fixes/features. πŸ˜‰

    #7779
    loxai
    loxai
    Keymaster

    That’s interesting. And that’s with both Trinus version having same settings (eg. Vsync enabled on both)?

    #7780

    acsdani
    Participant

    It doesn’t matter, I can set V-sync on, then off in the other. Still great!
    I can even switch FreePIE on/off.

    BUT there’s a problem with FreePIE in 0.9.6 …PSVR’s orientation is not working, and when I move (with a script) it’s ghosting a little bit.

    I tried this trick with 0.9.4c and it has good orientation with FreePIE and no ghosting!!!
    Here is the topic where you made 0.9.4c and solved the FreePIE flickering!
    “http://oddsheepgames.com/?topic=psvr-and-freepie-stopping”

    Can you put the 0.9.4c FreePIE mechanism into 0.9.6 ? πŸ™‚ That would be great!!! πŸ™‚

    #7784
    loxai
    loxai
    Keymaster

    Ok, a new test build. Try as is to see if it improves. If not, play with the test parameters in Advanced tab.
    https://trinusvirtualreality.com/files/psvrTest.zip
    Should be tested without FreePIE involved.

    #7785

    Dekaid
    Participant

    x64 not working for me at all, freezes when I start tracking
    V2 same as others before, the delayed start option still doesnt go above 90fps for me, I checked on the psvr display and it first reset it to 60hz, when I then changed it back to 120hz it went up to 90fps
    Played around with the advanced options of the new one, doesnt launch without moveWindow set to true, no picture without hookMethod set to true, resolution and all the other options seemingly didnt change anything tho.
    When I left hookMethod false, Steam Frame timing actually showed under 8ms timing with my cpu usage at 50% and gpu at 70%, no luck setting it back to true tho, as soon as I get video output it limits to 90fps it seems, only working one so far at 120fps was the PhoneVR_sdk.exe still.

    #7786

    acsdani
    Participant

    I also tried this new Test build (0.9.7d). It doesn’t improved. With the test parameters it doesn’t want to send headset display to the PSVR’s screen -so I have to use ALT+TAB, no matter how I change the parameters, nothing helped. And it still shows bad ghosting with async repr.
    _________
    Finally I got PSVR’s orientation working when FreePIE enabled in 0.9.6 with the “start with 0.9.2 trick”. (The problem was that my monitor was set to 2560×1080 instead of 1920×1080)

    The strange part is that with FreePIE it has that same ghosting issue when lauching via 0.9.6 or any other test build. The only difference is that this way it’s ghosting even when async repr. is OFF.

    And I can stop it and disable FreePIE and start again, and there’s no ghosting again.

    Hope this helps. πŸ™‚

Viewing 15 posts - 31 through 45 (of 53 total)

You must be logged in to reply to this topic.