Head tracking proposal.

Trinus Forum Forums Troubleshooting Head tracking proposal.

This topic contains 5 replies, has 2 voices, and was last updated by Avatar davinux 5 years, 7 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #2911
    Avatar
    davinux
    Participant

    Hi again,

    I’m having a lot of issues with the Head tracking in trinus (I’m sure the gyro in my device is not as good as It could be) but It’s working almost perfectly in every cardboard application.

    Is there any option that you’ll add the Cardboard SDK just to head tracking.

    https://developers.google.com/cardboard/android/latest/reference/com/google/vrtoolkit/cardboard/HeadTransform

    Maybe it will be easy…

    Thanks.

    • This topic was modified 5 years, 7 months ago by Avatar davinux.
    #2913
    loxai
    loxai
    Keymaster

    I will look into that. But first I’d like to know more about your experience: which sensor mode (in phone app settings) have you been using? have you tried the other ones?

    #2927
    Avatar
    davinux
    Participant

    Sorry for the delay, I´ve been off-line these days.

    About the sensor mode, I´m using mode 3. I´ve tried all of them and this one seems to be the best one.

    The issue is a little bit weird. It´s like the sensor values were mixing slowly. After some minutes if I move the head to one size, the mouse draw a circle. Seems like Google Cardboard is correcting the angles using the accelerometer too.

    BTW, if the last version of the server (1.9.1d) the Pitch cannot be inverted.

    #2928
    loxai
    loxai
    Keymaster

    hmm, not sure why would this be happening… you don’t have a magnet there in the Cardboard do you?

    regarding inverted axis, yes, I saw that, will have to look into it, but if you increase the sensitivity just a tiny bit it will invert correctly.

    #2931
    Avatar
    davinux
    Participant

    About the magnet, I’m using color cross and it hasn’t any magnet. I’ll make more test with other ROMs to be sure that is not a problem of the one I’m using right now.

    The inverted axis was a little bit confusing, because I use inverted mouse in games, and my head was moving in the other way around :). I’ll try and I’ll let you know. Thanks again!.

    #2938
    Avatar
    davinux
    Participant

    Hi Again. I´ve tried another ROM (and I calibrated the sensor from the engineering mode) and everything seems to work much better.

    In the other hand I wasn´t able to invert the axis. Thanks!.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.