Mouse tracking stops after a few seconds

Home Forums Troubleshooting Mouse tracking stops after a few seconds

This topic contains 38 replies, has 16 voices, and was last updated by loxai loxai 2 months, 3 weeks ago.

Viewing 15 posts - 16 through 30 (of 39 total)
  • Author
    Posts
  • #4867

    TheDegree0
    Participant

    Made a second run, might be useful, idk

    PI Log:

    2/7/2016 5:46:08 AM:Connection detect cancelled
    2/7/2016 5:46:08 AM:TGLIB:0:Set compression level 0
    2/7/2016 5:46:08 AM:TGLIB:0:Requesting config connection to 192.168.1.34:7777
    2/7/2016 5:46:08 AM:Waiting for connection, using ports 7777 and 5555
    
    2/7/2016 5:46:08 AM:TGLIB:0:Connected config
    2/7/2016 5:46:08 AM:TGLIB:0:Received config, target resolution 2560x1440
    2/7/2016 5:46:08 AM:TGLIB:0:Streaming video 1 and sensor 1
    2/7/2016 5:46:08 AM:TGLIB:0:Connection established (video)
    2/7/2016 5:46:08 AM:TGLIB:0:Video processor ready
    2/7/2016 5:46:08 AM:TGLIB:0:Requesting sensor connection to 192.168.1.34:5555
    2/7/2016 5:46:08 AM:Starting video capture (1)
    2/7/2016 5:46:08 AM:Streaming input TGServer (704x392)
    
    2/7/2016 5:46:08 AM:All set for TGServer 704x392 to 2560x1440
    2/7/2016 5:46:08 AM:Will resample: False 704x392 to 704x392 target 2560x1440 fake3d: False
    2/7/2016 5:46:08 AM:Starting mouse protocol
    2/7/2016 5:46:08 AM:TGLIB:0:Data callbacks set: Sensor,  Bitmap format
    2/7/2016 5:46:08 AM:TGLIB:0:Connection established (sensor)
    2/7/2016 5:46:10 AM:
    2/7/2016 5:46:10 AM:Streaming input TGServer (760x268)
    
    2/7/2016 5:46:10 AM:All set for TGServer 760x268 to 2560x1440
    2/7/2016 5:46:10 AM:Will resample: False 760x268 to 760x268 target 2560x1440 fake3d: False
    • This reply was modified 1 year, 9 months ago by  TheDegree0.
    • This reply was modified 1 year, 9 months ago by loxai loxai.
    #4873
    loxai
    loxai
    Keymaster

    Sorry guys, I still don’t have a solution for this. So far a trick that seems to help is lowering the quality (higher compression).
    Seems to happen in different versions, arbitrarily, and with different phones.
    Going to Advanced Mode, and looking at the capture/delivery/sensor rates. Does the sensor rate keeps updating and showing a number above 0? (that would mean phone is still delivering sensor info, but a bug is making it fail on the Trinus PC side).
    Is that with any (mouse related) tracking mode selected (mouse/mouse lock/auto)?
    Does enabling ‘Precision’ in Advanced Mode>Sensors tab make any difference?
    If you find any other impacting factor (like works for longer/forever in one game, or when setting some specific option), let me know.

    #4874

    TheDegree0
    Participant

    loxai said:

    Sorry guys, I still don’t have a solution for this. So far a trick that seems to help is lowering the quality (higher compression).
    Seems to happen in different versions, arbitrarily, and with different phones.
    Going to Advanced Mode, and looking at the capture/delivery/sensor rates. Does the sensor rate keeps updating and showing a number above 0? (that would mean phone is still delivering sensor info, but a bug is making it fail on the Trinus PC side).
    Is that with any (mouse related) tracking mode selected (mouse/mouse lock/auto)?
    Does enabling ‘Precision’ in Advanced Mode>Sensors tab make any difference?
    If you find any other impacting factor (like works for longer/forever in one game, or when setting some specific option), let me know.

    Tried disabling the Ignore Tracking feature on Advanced > Sensors but made no difference. I also tried setting it to a key on my keyboard to try and switch it on and off once it stopped working but it didn’t do anything either.

    Enabling precision movement does nothing. Tried different sensor outputs:
    Mouse, Mouse (lock), Virtual Desktop and Auto. Made no difference neither. Those are the only ones I could try. I’ll try FreeTrack and TrackIR next, I suppose it’s software you can download.

    I’ll check if the code is on GitHub later and make a fork to try and find where’s the issue originating from.

    • This reply was modified 1 year, 9 months ago by  TheDegree0.
    • This reply was modified 1 year, 9 months ago by  TheDegree0.
    • This reply was modified 1 year, 9 months ago by  TheDegree0.
    #4905

    TheDegree0
    Participant

    Update:
    It doesn’t happen over USB. I don’t know if you guys already knew that but… just for in case.

    Couldn’t find trinusvr or oddsheepgames on github.

    #4953

    Boike
    Participant

    Hi!

    Trinus VR V.2.0.6. With USB-Tethering.

    Have a similar problem. Mousetracking working as long as I play but it drifts to the right constantly.
    Tried setting Sensor Output to Freetrack but it stops after a few seconds, tried everything above.
    Opentrack does the same thing strangely enough, but just the output and to the left, input is stable (only got it to work with wifi) so cant use it at the same time with Trinus as USB-tethering stops when I activate Wifi on my phone.
    Using a Samsung Galaxy Note 4.

    #4957

    AlesCZ
    Participant

    Hi,
    I had a similar problem, not work Freetrack protocol. Not worked other applications for tracking IR LED. I had to delete Trinus somewhere in the registry. At the moment I can not remember what the folder, but it was a component of the protocol Freetrack or OpenTrack … potential TrackIR? I do not know, but again, it worked.

    • This reply was modified 1 year, 8 months ago by  AlesCZ. Reason: bad google translate
    • This reply was modified 1 year, 8 months ago by  AlesCZ.
    #4965

    AlesCZ
    Participant

    Naturalpoint folder I think 🙂

    #4974

    AlesCZ
    Participant

    Strange. First Freetrack protocol stopped working after ten seconds and now, not at all. I do not know how to solve it.

    #4975

    AlesCZ
    Participant

    So,
    USB Tracking does not work
    Over WiFi only about 5 seconds

    #5042

    mr_sarge
    Participant

    Same problem here. Freetrack stop after 5 to 10 seconds in EST2 using WiFi. Was unable to make it work with USB

    #5223

    Tommy544
    Participant

    Hello,

    I have the same problem. FreeTrack tracking works for about 5 seconds and then just stops. It is the same on USB and WiFi connection. I tried it on my Samsung Galaxy S6 (Android 6.0.1) smartphone, if that helps.

    Could you please look into this issue? Are there any diagnostic steps I could try that might help you?

    Tommy

    #5282

    RachelWolfe
    Participant

    Hey! Also checking in with this issue, my devices are OnePlus One and HTC One M8. I’ve used exclusively USB so far, and using FreeTrack with Euro Truck Simulator 2, I have about enough time to switch to the game window, put the headset on, and turn my head before the tracking just stops. I’m going to be so late for this delivery.

    Tracking previously didn’t work at all, so I’ve sort of made a bit of progress ish.

    Are there any logs I can look into, I can’t find a log within the server app.

    #5311
    loxai
    loxai
    Keymaster

    In order to see if the issue is on the server or the client side, can somebody with this problem try any of the Trinus games (Survival, Pigeon Poop, all at trinusvr.com) to see if it still happens without the Trinus server?

    #5349

    Atomregen
    Participant

    Hi, this problem also exists in SURVIVAL SHOOTER.

    #5350
    loxai
    loxai
    Keymaster

    Thanks for the update @atomregen.
    To you, and all the rest having this issue. There’s one point that might be worth checking. When you say the tracking stops working, the image is still being updated, right? ie. if you move the mouse or do some other action that changes the game view, the view on the phone is also updated.

    I mention this because there was a bug that froze the image, which may look like a tracking failure since the phone image won’t update. This was fixed recently.

Viewing 15 posts - 16 through 30 (of 39 total)

You must be logged in to reply to this topic.