Note4 screen scalling off

Trinus Forum Forums Troubleshooting Note4 screen scalling off

This topic contains 36 replies, has 7 voices, and was last updated by Avatar needlemsk 5 years, 1 month ago.

Viewing 15 posts - 1 through 15 (of 37 total)
  • Author
    Posts
  • #1842
    Avatar
    jackwiffs
    Participant

    Since your bigger overhaul of the app in the last to updates or so, the stream to my Note 4’s screen has been scaled wrong. for example if the window i’m streaming is “full screen” the image displayed on the phone screen is only showing the top left corner. show from left-right and top-bottem about 75% of the screen is seen. changing the settings or no matter the app, the only program that displays right is the Trinus Gyre server. this issue came up with the last few updates. any fixes?

    #1843
    loxai
    loxai
    Keymaster

    I understand you are currently using latest 1.9, and that wasn’t happening with which version?
    when you say ‘full screen’ you mean a window that takes the full screen?
    does the window fit fully in the monitor?
    if you set the window to be less than ‘full screen’, does it also happen?
    what mode are you using, fast or compatible?
    please send debug console log when you try again, and let me know the resolution of the incorrectly displayed window.

    #1915
    Avatar
    jackwiffs
    Participant

    Sorry for delay on responding-

    ok to try and answer all the questions.
    its running 1.9 and had issue on version 1.8 but fine on one b4 that.
    it doesn’t matter size of window or rez on my computer(screen is 1920×1080)
    ive tried to use different programs and even native rez lowered or upscaled it always uses same portion of screen. ( http://i384.photobucket.com/albums/oo282/jackwiffs/Screenshot_2015-01-03-11-43-24_zps973cb615.jpg)
    this link should it work is a screen shot of the phone trying to display your web page
    the streaming source shows as 1536×844 to 2560×1440
    only thing it seems to get to fix screen right is the desktop serve app.

    i’ve used fast/compatable, high/low, qualities
    ill send the debug console log but idk how to find it

    #1916
    Avatar
    jackwiffs
    Participant

    also, i’ve tired other streamers, kainy does the same effect but splashtop is able to stream correctly

    #1919
    loxai
    loxai
    Keymaster

    you can check the debug console by clicking on the Pi sign. would you get the chance to try with a different phone and the same computer (to narrow it down to the client side)? also, have you tried resolutions equal or higher than the phone’s?

    #1927
    Avatar
    jackwiffs
    Participant

    {
    TGLIB:0:Waiting for client at port 7777
    TGLIB:0:Connected auto
    TGLIB:0:Requesting config connection to 192.168.1.22:7777
    TGLIB:0:Ended connection auto
    TGLIB:0:Connected config
    TGLIB:0:Received config, target resolution 2560×1440
    TGLIB:0:Streaming video 1 and sensor 0
    TGLIB:0:Connection established (video)
    TGLIB:0:Video processor ready
    TGLIB:0:Sensor streaming disabled
    Starting video capture (Compatible mode)
    All set for TGServer 894×320 to 2560×1440
    TGLIB:0:Data callbacks set: No sensor, Bitmap format
    All set for TGServer 767×270 to 2560×1440
    }
    this is data from it connecting to note 4

    i’ve tried note2 and a galaxy s4 the note2 fully failed to connect
    shows a white screen with black box and reports
    {
    All set for TGServer 767×270 to 1280×720
    All set for TGServer 767×270 to 1280×720
    All set for TGServer 767×270 to 1280×720
    }
    untill i cancel and final report for it is
    {
    All set for TGServer 767×270 to 1280×720
    All set for TGServer 767×270 to 1280×720
    All set for TGServer 767×270 to 1280×720
    All set for firefox 1536×844 to 1280×720
    TGLIB:0:Resampling source to match target 1536×844 to 1280×720
    All set for TGServer 894×320 to 1280×720
    TGLIB:0:User stopped server
    Stopping video capture
    TGLIB:0:Stopping video
    TGLIB:0:Stopping connection config
    TGLIB:0:Connection config stopped
    TGLIB:0:Video stopped
    TGLIB:0:Stopping connection config
    TGLIB:0:Connection config stopped
    }

    the galaxy s4 does he same as note 4

    #1928
    Avatar
    jackwiffs
    Participant

    this is the changing of native screen resolutions

    All set for TGServer 767×270 to 2560×1440
    All set for explorer 1680×317 to 2560×1440
    All set for explorer 1680×987 to 2560×1440
    All set for explorer 1680×317 to 2560×1440
    All set for TGServer 767×270 to 2560×1440
    All set for explorer 301×431 to 2560×1440
    TGLIB:8:Current aspect ratio will appear widened in fake3D mode
    All set for explorer 1680×987 to 2560×1440
    All set for explorer 352×125 to 2560×1440
    All set for explorer 1536×813 to 2560×1440
    All set for explorer 1536×241 to 2560×1440
    All set for TGServer 767×270 to 2560×1440

    Lowering from 1920×1080 fixes issue of showing less screen
    1650×1050 or lower rez will display a border-less window
    desktop fails to show task bar and wallpapers
    otherwise changing modes makes most apps used to work
    so issue seems to be the 1080 native rez

    #1946
    loxai
    loxai
    Keymaster

    a couple more checks:
    does this happen with both Fast and Compatible modes?
    if the full size window (desktop or browser) is the first thing to show, does it still happen? to test this, start server first, switch to browser/desktop and then start client

    #2011
    Avatar
    jackwiffs
    Participant

    it happens in all modes on full 1080 no matter fast or compatible.
    didn’t matter if desktop was first to show or not
    only seems to matter on what the native resolution is

    #2049
    Avatar
    TheRealTJ
    Participant

    Hey, Galaxy S4 here having the exact same issue. Oddly though when going into lens calibration it streams correctly (the calibration itself streams correctly, after completing that and switching to any other program it only streams part of the screen.)

    #2060
    Avatar
    Seboss-fi
    Participant

    Hey guys, I’m using Nexus 5 (5.0.1) and experiencing the same issues. Running on my Surface pro (1st Gen with Win 8.1). Thanks!

    #2089
    loxai
    loxai
    Keymaster

    trying to get this fix, but it’s tricky because of I cannot reproduce the issue. Please check the pre-release at https://www.dropbox.com/s/f5dmai0xujl2kkn/TrinusGyreSPreRelease1.9.1.zip?dl=0

    #2117
    Avatar
    needlemsk
    Participant

    Hi all! I had a similar problem. Lenovo k900 + amd 7970 + win 8 + tridef. The solution is to use win 7. I have everything working. No more trimming of the screen.
    In trinus gyre console: win 8 – 1536×864 to 1920х1080, win 7- 1920х1080 to 1920х1080.
    Black mesa and alien isolation – ok.

    #2152
    Avatar
    stvad
    Participant

    Hi, I have the same issue on
    Galaxy Note IV and on Galaxy Note I.
    Server configuration – Surface pro 1 (win 8.1, i5, hd4000)
    I was not able to connect to pre-release (1.9.1) server, posted above, using 1.9 stable client. (Do I need to use pre-release client? And if yes, where can I get one?)

    #2154
    loxai
    loxai
    Keymaster

    @stvad, yes you need the 1.9.1 client, which is included in the server zip.
    I’m very keen on getting this issue sorted, so please let me know if the scaling is still off.

Viewing 15 posts - 1 through 15 (of 37 total)

You must be logged in to reply to this topic.