PSVR black display

Home Forums Trinus PSVR PSVR black display

Tagged: 

This topic contains 5 replies, has 4 voices, and was last updated by  Caelum_NL 6 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #6856

    Caelum_NL
    Participant

    I got the PSVR connected as displayed in the how to of Beta 5.4, got past the xUSB error, tracking in mouse mode works and Steam VR recognises my PSVR too as I get no errors in the setup and on my PC screen the headdtracking works too.

    The problem is that my PSVR only outputs a black screen. I got an AMD RX480 (and changed the pixel format to the RGB 4x4x4 thing, tried both options) which should be sufficient to run a PSVR on my comp, I thought. Am I doing something obviously wrong? switching screens with windows key+ shift+ arrows didn’t do much either.

    • This topic was modified 8 months, 1 week ago by  Caelum_NL.
    #6862

    Sors
    Participant

    Hi,

    I have the same problem, but put my support request on reddit (https://vr.reddit.com/r/TrinusVR/comments/5umd4a/trinuspsvr_steam_mode_not_working_sbs_mode_works/).

    The problem is not yet solved, and I am waiting for further support since about 2 weeks, but Ioxai put the TestVersion link up there, perhaps this solves your problem.

    #6949

    vrpiet
    Participant

    Hello,

    I tried to play Vanishing of Ethan Carter VR. It starts and i can see the SBS-Picture without Audio on my PC-Monitor. Phone Screen stays black.
    The normal Ethan Carter with Capture Mode “Game” and Sensor Mode “Mouse” i can play for hours without any problems
    with Fake3D and Fakeroll(high , no compression, 5ghz wlan).
    I only have the Back Screen issue in Capture Mode “SteamVR”. Tracking with “FreepieIO” is OK.

    I found this in the Logfiles from Steam:

    vrserver.txt:
    ————-
    .
    .
    .
    Fri May 12 2017 19:54:34.528 – phonevr: Server Init
    Fri May 12 2017 19:54:34.528 – driver phonevr implements interfaces ITrackedDeviceServerDriver_005 IVRDisplayComponent_002 IVRDriverDirectModeComponent_002 IVRControllerComponent_001 IServerTrackedDeviceProvider_004
    Fri May 12 2017 19:54:34.528 – Loaded server driver phonevr (IServerTrackedDeviceProvider_004) from D:\Spiele\Steam\steamapps\common\SteamVR\drivers\phonevr\bin\win64\driver_phonevr.dll

    —>>> Fri May 12 2017 19:54:34.528 – Driver phonevr has no suitable devices. ????

    Fri May 12 2017 19:54:34.528 – Not loading driver null because it is disabled in settings
    Fri May 12 2017 19:54:34.528 – No connected devices found. Returning best error VRInitError_Init_HmdNotFound
    Fri May 12 2017 19:54:34.528 – Allowing driver load failure VRInitError_Init_HmdNotFound for application vrmonitor (7256) because it is vrmonitor
    Fri May 12 2017 19:54:34.528 – Processing message VRMsg_Connect from vrmonitor (7256) took 1.98 seconds
    Fri May 12 2017 19:54:34.529 – PoseUpdated for invalid object ID 4294967295
    Fri May 12 2017 19:54:34.542 – phonevr: CTrackedDeviceServerDriver::Activate(0)
    Fri May 12 2017 19:54:34.542 – phonevr: SN: 01
    Fri May 12 2017 19:54:34.542 – phonevr: Tracked data valid: 1
    Fri May 12 2017 19:54:34.542 – Active HMD set to phonevr.01
    Fri May 12 2017 19:54:34.543 – PoseUpdated for invalid object ID 4294967295
    Fri May 12 2017 19:54:34.553 – PoseUpdated for invalid object ID 4294967295
    Fri May 12 2017 19:54:34.563 – PoseUpdated for invalid object ID 4294967295
    Fri May 12 2017 19:54:34.573 – PoseUpdated for invalid object ID 4294967295
    Fri May 12 2017 19:54:34.583 – PoseUpdated for invalid object ID 4294967295
    Fri May 12 2017 19:54:34.593 – PoseUpdated for invalid object ID 4294967295
    Fri May 12 2017 19:54:34.603 – PoseUpdated for invalid object ID 4294967295
    Fri May 12 2017 19:54:34.613 – PoseUpdated for invalid object ID 4294967295
    Fri May 12 2017 19:54:34.623 – PoseUpdated for invalid object ID 4294967295
    Fri May 12 2017 19:54:34.633 – PoseUpdated for invalid object ID 4294967295
    Fri May 12 2017 19:54:34.653 – PoseUpdated for invalid object ID 4294967295
    Fri May 12 2017 19:54:34.663 – PoseUpdated for invalid object ID 4294967295
    Fri May 12 2017 19:54:34.663 – New Connect message from D:\Spiele\Steam\steamapps\common\SteamVR\bin\win32\vrcompositor.exe (VRApplication_Background) (Args: ) 7724
    Fri May 12 2017 19:54:34.665 – Creating builtin app for D:\Spiele\Steam\steamapps\common\SteamVR\bin\win32\vrcompositor.exe (VRApplication_Background)
    Fri May 12 2017 19:54:34.665 – Setting app system.generated.vrcompositor.exe PID to 7724
    Fri May 12 2017 19:54:34.665 – Using existing HMD phonevr.01
    Fri May 12 2017 19:54:34.673 – PoseUpdated for invalid object ID 4294967295
    Fri May 12 2017 19:54:34.683 – PoseUpdated for invalid object ID 4294967295
    Fri May 12 2017 19:54:34.693 – PoseUpdated for invalid object ID 4294967295
    Fri May 12 2017 19:54:34.703 – PoseUpdated for invalid object ID 4294967295
    Fri May 12 2017 19:54:34.713 – PoseUpdated for invalid object ID 4294967295
    Fri May 12 2017 19:54:34.723 – PoseUpdated for invalid object ID 4294967295
    Fri May 12 2017 19:54:34.733 – PoseUpdated for invalid object ID 4294967295
    Fri May 12 2017 19:54:34.743 – PoseUpdated for invalid object ID 4294967295
    .
    .
    .

    vrclient_vrcompositor.txt
    ————————-

    Thu May 11 2017 23:03:58.451 – //=====================================================================================================================
    Thu May 11 2017 23:03:58.451 – vrclient startup with PID=5196, type=VRApplication_Background, config=D:\Spiele\Steam\config
    Thu May 11 2017 23:03:58.453 – [Settings] Load Default Json Settings from D:\Spiele\Steam\steamapps\common\SteamVR\resources\settings\default.vrsettings
    Thu May 11 2017 23:03:58.453 – [Settings] Load Default Json Settings from D:\Spiele\Steam\steamapps\common\SteamVR\drivers\lighthouse\resources\settings\default.vrsettings
    Thu May 11 2017 23:03:58.454 – [Settings] Load Default Json Settings from D:\Spiele\Steam\steamapps\common\SteamVR\drivers\null\resources\settings\default.vrsettings
    Thu May 11 2017 23:03:58.454 – [Settings] Load Json Settings from D:\Spiele\Steam\config\steamvr.vrsettings
    Thu May 11 2017 23:03:58.466 – Received success response from vrserver connect

    —>>> Thu May 11 2017 23:03:58.473 – Failed to find interface ‘IVRVirtualDisplay_001’ ????

    Thu May 11 2017 23:04:00.568 – [Chaperone] Universe changed from 0 to 2.
    Thu May 11 2017 23:04:00.570 – Collision Bounds distances: flMinAxis=1.000000, Hmd=0.350000->0.700000, Controllers=0.262500->0.525000
    Thu May 11 2017 23:04:00.595 – Loaded image D:\Spiele\Steam\steamapps\common\SteamVR\resources\backgrounds\transition_background.png (2048×1024)
    Thu May 11 2017 23:04:02.519 – Loaded image D:\Spiele\Steam\resource\icon_steam_vr.png (300×300)
    Thu May 11 2017 23:04:03.216 – Loaded image D:\Spiele\Steam\steamapps\common\SteamVR\resources\darkgrey.png (16×16)
    Thu May 11 2017 23:04:03.257 – Loaded image D:\Spiele\Steam\steamapps\common\SteamVR\tools\content\panorama\images\dashboard_controls_background.png (1920×640)
    Thu May 11 2017 23:04:03.310 – Loaded image D:\Spiele\Steam\steamapps\common\SteamVR\tools\content\panorama\images\dashboard_active_background.png (800×800)
    Thu May 11 2017 23:04:03.489 – Loaded image D:\Spiele\Steam\resource/icon_steamvr_desktop.png (512×512)

    #6954

    poiuytrewq4645
    Participant

    @vrpiet if I were you I would set tracking to auto

    #6955

    vrpiet
    Participant

    same result

    #6959

    Caelum_NL
    Participant

    Ok, tried to connect PSVR to PC again after a while, but now I had the HDMIx error. I had searched for any solution, but couldn’t get any of them to work. Seemed like it was a matter of Windows key + P to switch to extended screen mode. Had to do a few restarts, but somehow, I got an image on my PSVR now of my desktop. And miraculously, I also can switch with Windows key + shift + arrows left/right to switch between screens 😀

    Ioxai, may I suggest putting the Extended screen tip in the troubleshooting under HDMI not connected? I know that it’s also in the setup screen, but maybe more people miss it there.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.