Red display in HMD

Trinus Forum Forums Trinus PSVR Red display in HMD

This topic contains 4 replies, has 5 voices, and was last updated by Avatar cheater 1 year, 5 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #8100

    Hello, hopefully someone has a fix to the Red display in the HMD making Project cars 2 unplayable as I can’t control the menu.

    I run Trinus vr, everything works fine, HMD displays at 90hz.

    I run Project cars 2, it displays in my monitor.

    My HMD has a red display, I click the red display and the game displays in both the monitor and the HMD.

    The game menu loads into the HMD and looks perfect, however I can’t control the game menu unless the game window is selected.

    I select the game window and the HMD display goes completely red.

    I click the red HMD display and the menu comes back but I can’t use mouse or keyboard etc.

    I click the game window and have control of the menu on my monitor but a red HMD display…

    Rinse and repeat.

    Nothing appears to fix this.



    Go to the advanced settings of trinuspsvr and uncheck the full screen of steamvr and you’ll see that the psvr screen will not be red try again!


    I know this is a few months old but this is the exact problem im having,

    did you find a way to solve it?

    i cant see anything in advanced settings to uncheck for full screen steamvr?


    I have the same issue, I always have to click the red screen (Steam Compositor Window) to get VR picture, but then no control inputs are detected whatsoever. If I select the game window, screen turns red, but controls are detected.

    Steam Media Player App, for example, behaves even weirder, as it does show the screen and does show the mouse, but I can’t click on anything, only if I drag the Steam Media Player window to another screen does it allow input.

    And to make things worse, if I try to drag windows from other games to another screen, I’ll get BSOD…


    The BSOD sounds like a driver issue. What GPU and drivers are you using?

    The red display could be due to a series of issues. Have you searched the forum? There’s a lot of posts about this, all suggesting different fixes. Let us know what you have tried already from the posts you have found in the forum, and we’ll be able to suggest things you haven’t tried yet.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.