SteamVR fps drop in current version (0.9.3)

Trinus Forum Forums Trinus PSVR SteamVR fps drop in current version (0.9.3)

Tagged: , ,

This topic contains 28 replies, has 4 voices, and was last updated by Avatar mugen 2 years, 1 month ago.

Viewing 14 posts - 16 through 29 (of 29 total)
  • Author
    Posts
  • #7617
    Avatar
    mugen
    Participant

    Do you mean if that message appears in the drop down menu for display selector? If so, no it does not. I only see diaply1,display2, display3 or blank. As for the link you posted I will try it out tonight or tomorrow and report back.

    #7618
    loxai
    loxai
    Keymaster

    No, I mean the bottom messages area

    #7620
    Avatar
    wdnnl
    Participant

    Update:
    When I was testing the testbuild “f” version yesterday, I noticed that my previous environment had a error. The headset was not 120hz, but 60hz. So I retested the performance of the two refresh rates. Under the extended mode. whtn HMD set to 120hz, swinging the headset to the left and right will have serious ghosting, and 60hz will be much better. This is very unreasonable? I think that if only the monitor is 120hz, headset setting 120hz can really improve performance, but if the monitor and head refresh rate are different, it will cause ghosting(under the extended mode).

    #7621
    Avatar
    wdnnl
    Participant

    What is the “Alt. Display Select Mo” in the Advanced tab? I can’t get any info for it,

    #7622
    loxai
    loxai
    Keymaster

    afaik, it was always the case that all displays needed to be at same refresh rate.
    The Alt. Display select is an alternative way to move the window, for when the default doesn’t work.

    Updated https://trinusvirtualreality.com/files/psvrTest.zip, tests to try:
    – setting PSVR Display selector to none (—) vs a display
    – enabling/disabling vsync in Advanced tab
    – setting vsync timing to 0 vs med/high value

    Just to make sure we are on the same page, state which version number are you testing, the gpu used and if using SteamVR or SteamVR Beta.

    Thank you guys for your patience and support. Hope we can sort this one out soon!

    • This reply was modified 2 years, 2 months ago by loxai loxai.
    #7624
    Avatar
    wdnnl
    Participant

    @loxai
    Testbuild “g” + steamVR [openvr-imputemulator-temporary] ver:1512445023
    i7 8700/8G/gtx1066/sandisk 240ssd.

    test1:– setting PSVR Display selector to none (—) vs a display
    set selector to –,the compositor window always showing up on main monitor;
    set selector to display2(hmd), the compositor window almost showing up in HMD. sometimes it does not work.

    test2:– enabling/disabling vsync in Advanced tab.
    enabling/disabling vsync , The difference is not obvious and cannot be measured accurately.

    test3:– setting vsync timing to 0 vs med/high value.
    The difference is not obvious for me.I don’t have fps test tool and can’t display real time fps.

    The above test results apply to 2x and 5x supersampling(via steamvr-setup-developer):
    gpu load(gpu-z)
    2x: under 50%
    3x: under 60%
    5x: under 80%

    #7625
    Avatar
    Xero
    Participant

    I can only seem to get it working using the ‘Alt. Display Select Mode’, which I presume is similar to the old method?

    This is my method, and works every time. Hopefully it can help some others. There’s a few extra steps in there from before the update though.

    Step 1: Launch TrinusPSVR
    Step 2: Select ‘Advanced’ tab and tick ‘Alt. Display Select Mode’
    Step 3: Select ‘Main’ tab and select ‘DISPLAY 2’ from ‘PSVR Display’ drop down list
    Step 4: Press ‘Start’ button

    Step 5: Launch SteamVR
    * Note: Compositor will launch on to the monitor (DISPLAY 1)
    * Note: Before update this would have launched into the headset in windowed mode

    Step 6: Alt-Tab and open SteamVR Settings, select ‘Advanced’ tab, and click ‘Disable Direct Mode’
    * Note: This re-launches the compositor in a slightly different mode that will seek to go full screen on a multi-display setup (observation from my extensive testing over the past year)
    * Note: This will relaunch the compositor on to the monitor again (DISPLAY 1)

    Step 7: Alt-Tab to TrinusPSVR
    * Note: This time when you Alt-Tab, the compositor should jump across to the headset (DISPLAY 2), but will be in windowed mode

    Step 8: Press ‘Stop’ button, and then ‘Start’ button again
    * Note: This should kick the compositor on the headset (DISPLAY 2) into full screen mode

    As I said, there’s a few extra steps in there from before the update. Pressing ‘Disable Direct Mode’ in SteamVR settings would have launched the compositor in fullscreen mode directly into the headset.

    #7626
    Avatar
    wdnnl
    Participant

    @xero:
    “Disable direct mode” have the compositor to go directly to the HMD. Are you sure? what about the performance with that? my understanding is to enable direct mode, unfortunately, I have never been able to get direct mode to work on my PSVR, the whitelist trick does not work, forcing directmode in steamvr.vrsettings too.

    #7627
    loxai
    loxai
    Keymaster

    @xero
    thanks for the detailed steps

    @all
    I’ve updated the build once more solving a race condition (a timing issue where Trinus tries to move the SteamVR window once its running but before the window has been actually created).
    I’ve also removed a call to make the window maximised, thinking this may cause to go from fullscreen to maximised window. So it may now stay fullscreen, if that’s how SteamVR opens it by default (otherwise, the Disable Direct Mode trick will still be necessary).

    #7628
    Avatar
    Xero
    Participant

    @wdnnl
    I think you may have misunderstood me. Direct Mode doesn’t work with PSVR, but the first time the compositor launches it seems it tries to launch with direct mode settings in mind. This means the PSVR headset never gains full screen mode (for me anyway), which is where the smooth performance lies. Pressing ‘Disable Direct Mode’ appears to relaunch the compositor with different settings which allows full screen to happen on the headset in extended mode. The choppy FPS issues a lot of people are having is because the compositor is running in a maximized window mode.

    @loxai
    Tried the update, still have to use ‘Alt. Display Select Mode’ in order to get full screen on the headset using my method from before. In the default select mode the window is switching to the correct display now, so some progress there. I just can’t seem to get it to grab full screen though.

    • This reply was modified 2 years, 2 months ago by Avatar Xero.
    #7634
    loxai
    loxai
    Keymaster

    Ok, will focus on getting fullscreen working… this is going to take a while to sort out. In the meantime, it seems @xero‘s workaround is the best way to go.

    #7641
    Avatar
    mugen
    Participant

    Version 9.3h and still have low FPS issue.

    Another issue I’m now having is ever since I started trying these test build I have to re enter my activation codes every-time i restart my PC. And I don’t mean if i try different builds. I mean if I open build 9.1(the last working build for me) and enter activation code it accepts the code and all is good. If I restart the PC and immediately open build 9.1 again I need to re enter activation code. And worst part is if I forget after 10 minutes of play the HMD goes black.

    #7655
    loxai
    loxai
    Keymaster

    Ok, so after much trial and error, I found the culprit for the no fullscreen issue.
    The bad news is that, when fixing that, I’m not able to move the compositor to a different display.
    The temp workaround is to switch Windows main display. Definitely not a good option, but I leave the updated build here so you can at least test and use like this until I find a better solution.
    As usual: https://trinusvirtualreality.com/files/psvrTest.zip

    @mugen, there was a bug in 0.9.1 that caused the ‘forgotten license’ issue you mention

    #7718
    Avatar
    mugen
    Participant

    I downloaded the latest update from your website and it now launches properly, however I’m still having low FPS issue. Any time frame for when this will be fixed, or anyway to fix the forgotten licence in version 0.9.1

Viewing 14 posts - 16 through 29 (of 29 total)

You must be logged in to reply to this topic.